Join the YKS community







Chat - General koi related chat!

Graham"chilodonella" 10:41am Friday 31st Aug
joined: 13th Jun 17
last here: 11:32am Sunday 11th Nov
posts: 4
from: Hessle, East Yorkshire

Hi , this is my first post and it is asking for help with a massive problem I have with chilodonella in my 30000 L pond. I am losing fish almost every day now. I have done scrapes and identified the problem as being chilodonella . up to now I have treated with ( 0.3 % ) removed the salt with water changes, treat with PP WAITED A WEEK then used FMG, waited another week then used FMG again all with masses of extra aeration.
Done more scrapes, microscoped and they are still there.
Has anyone any ideas on what to treat with next.
Got to do something quick as out of 30 fish ranging from 30 inches to 6 inches I have lost 10, some big ones, some little ones . don't know what to do next .
HELP.
Graham


Graham javascript:smile('')
big h"RE: chilodonella" 3:32pm Friday 31st Aug
joined: 1st Oct 06
last here: 4:54pm Monday 12th Nov
posts: 1464
from: howden

where are you graham
Graham"RE: chilodonella" 6:26pm Friday 31st Aug | message edited 2 times
joined: 13th Jun 17
last here: 11:32am Sunday 11th Nov
posts: 4
from: Hessle, East Yorkshire

Hi Big h, I am in Hessle east Yorkshire. My Phone No is 07710510298
e mail graham@gstarview.karoo.co.uk


Graham javascript:smile('')
big h"RE: chilodonella" 8:44am Saturday 1st Sep
joined: 1st Oct 06
last here: 4:54pm Monday 12th Nov
posts: 1464
from: howden

see you at 11 am Graham .A fresh pair of eyes may help


Back to Topics




©2018 The Yorkshire Koi Society | Terms and Conditions | webmaster tonyw | graphics dave_norm_smith